Monday, December 7, 2009

VMWare server 2 "empty" screen with "Loading..." in the title

I've installed the VMWare server, and as many, hit the issue of an empty screen.

It appears to happen upon the subsequent logins. Obviously "empty screen" can be caused by a lot of errors, but in my case it seems to be some SSL-related issue, in /var/log/vmware/hostd.log I saw:

[2009-12-07 11:58:12.150 'Proxysvc' 1093462352 warning] SSL Handshake on client connection failed: SSL Exception:
[2009-12-07 11:58:12.316 'Proxysvc Req00102' 1081919824 warning] PendingServerStrm: client write-completion error: SSL Exception: error:00000001:lib(0):func(0):reason(1)
[2009-12-07 11:58:12.573 'Proxysvc Req00101' 1081919824 warning] PendingServerStrm: client write-completion error: SSL Exception: error:00000001:lib(0):func(0):reason(1)

What seems to help - is holding the Control key and hitting the "reload" button when I am on the page that does not show anything.

Then the page reloads fully and I get the login prompt to login into the VM.

Hope this is useful to someone.

I later tried on the ff-3.5, and there Ctrl-Shift-R for reload, apparently did the trick as well.

6 comments:

ck said...

just remove or rename /usr/lib/vmware/lib/libssl.so.0.9.8/libssl.so.0.9.8 so that the lib under /usr/lib is used.

Ben said...

@CK

DID NOT WORK

Andrew Yourtchenko said...

@Ben: Did the "reload" hack work though ? I'm curious, as for me it happened once again, and it did help again.

@ck: it was infrequent enough for me to not go to this kind of drastic measures.. Next time, maybe. Will post if I try it.

Me said...

@CK Seemed to work, but only after rebooting the host (Debian Lenny)

McDiesel said...

The libssl rename works on Lucid AMD64.

mv /usr/lib/vmware/lib/libssl.so.0.9.8 /usr/lib/vmware/lib/disabled-libssl.so.0.9.8
service vmware-mgmt restart


In firefox 3.6
Ctrl-shift-R

Andrew Yourtchenko said...

@McDiesel: Thanks, hopefully it helps some folks.